Трабла с формой входа (логина)

Вадим

Автор темы
Сообщения
15
Репутация
3
Баллы
3
Всем салам :)

В общем, есть форма входа, вот код:
HTML:
    <form action="<?php echo$Eleanor->Url->special.$Eleanor->Url->Construct(array('module'=>$ma,'do'=>'login'),false,'')?>" method="post">
            <div class="logintext">
                <span><?php echo$ltpl['login']?></span>
                <div><div><input type="text" name="login[name]" tabindex="1" /></div></div>
            </div>
            <div class="logintext">
                <span><?php echo$ltpl['pass']?></span>
                <div><div><input type="password" name="login[password]" tabindex="2" /></div></div>
            </div>
            <div style="text-align:center">
                <div style="padding-bottom: 6px;"><input value="<?php echo$ltpl['enter']?>" class="enterbtn" type="submit" tabindex="3" /></div>
                <a href="<?php echo Eleanor::$vars['link_register']?>"><?php echo$ltpl['register']?></a> | <a href="<?php echo Eleanor::$vars['link_passlost']?>"><?php echo$ltpl['lostpass']?></a>
<hr /><?php include Eleanor::$root.$theme.'Static/external_auth.php'?>
            </div>
        </form>
А я пытаюсь натянуть другое оформление. Сделал так:
HTML:
   <form action="<?php echo$Eleanor->Url->special.$Eleanor->Url->Construct(array('module'=>$ma,'do'=>'login'),false,'')?>" method="post">
                                
                                <label for="login_name"><span><?php echo$ltpl['login']?></span>
                                    <input type="text" name="login[name]" tabindex="1" class="f_input" id="login_name" />
                                </label>
                              
                                <label for="login_password"><span><?php echo$ltpl['pass']?></span>
                                    <input type="password" class="f_input" name="login[password]" tabindex="2" id="login_password" />
                                </label>
                                <div align="center"><button onclick="submit();" type="submit" tabindex="3" ><?php echo$ltpl['enter']?></button></div>
                                <input name="login" type="hidden" id="login" value="submit" />
                            </form>
Т.е я взял нужные параметры от старого и прописал в новый код типа name="login[name]" и т.д. Но при попытке входа выдает ошибку, т.е что-то не так сделал((